KQL Samples
Check for processname within accountdomain
// Check for process RDCMan in "FunkyDomain"
DeviceProcessEvents
| where AccountDomain == "FunkyDomain"
| where FileName has "RDCMan"Failed logins in Azure
// Failed logins to Azure, timechart
SigninLogs
| where TimeGenerated > ago(14d)
| where ResultType in ("50126", "50053" , "50055", "50056")
// 50053 Account is locked because the user tried to sign in too many times with an incorrect user ID or password.
// 50055 Invalid password, entered expired password.
// 50056 Invalid or null password - Password does not exist in store for this user.
// 50126 Invalid username or password, or invalid on-premises username or password.
| summarize Count=count() by bin(TimeGenerated, 1h)
| render timechart Finding changed permissions in a sharepoint site
Sentinel Table Growth
Find computer/user who connected to an IP
Extracting applocker events
Finding sysmonlogs
Finding SMBv1 audit data (if you have enabled auditing!)
MDE billable data
Find all wifi SSID names people have connected to
Last updated